Please or Register to create posts and topics.

Front-end profile editing

PreviousPage 3 of 4Next

And here is the edit-profile feature merged into Asgaros Forum 2.9.


Uploaded files:

@jim, I can’t get this to work. I have a clean install of 2.9 with no actions or filters in my functions.php. I followed your instructions for installing it.

Now, on the Profile page I have a new option on the menu bar called Edit Profile that goes to but when I click it it goes to the main forum page and not to an edit screen.

Have you confirmed this is working with 2.9? Any ideas as to what I can try? Thanks for any assistance!

@johnstaples Yes, the Asgaros 2.9 edit-profile version works for me, on my site.  I registered for your site and there are a number of differences.  For example, the Edit Profile  link on your site is below the profile, in mine it is above the profile, in the menu with Profile and Post History.  When I click it, it doesn’t go to the main forum page, as it does for you.  It goes to the back end profile editing screen.  Try it with a regular user (not admin) and see if you have a different experience.  I may need a day or two to think about what might be causing this.

Hi @jim and thank you for responding so quickly!

Sorry for the confusion but I had restored my site to the standard 2.9 installation and that’s why you saw the Edit Profile link below the profile and why it links to the backend WP screen.

But now I have changed it back to your version of 2.9 so if you get a chance to look at it again I would greatly appreciate any ideas you might have as to why it doesn’t work for me.

Thank You!

@johnstaples  Would you please try using the Site Health plugin, Troubleshooting mode?  It will disable all plugins and switch to default theme if you have one installed (like Twenty Twenty-Three).  If you don’t have a default theme, it will offer to install it for you.  This will only be for you – it won’t affect the public-facing site.

Then, in the troubleshooting screen, enable Asgaros Forum, and go to the front end and check it out.  It will look different of course.  Go to your profile and then the Edit Profile link and see if it goes to the main forum page, as before, or to the edit profile page, as it should.

If you do go to the edit profile page, then you need to start enabling and disabling things to find out if what breaks it, your theme or some plugin.  Let me know.

If you still go the main forum page with all other plugins off and default theme, then we need to consider whether some forum settings are incompatible with the modified version.

Thanks @jim! I followed your instructions as listed below…

  • installed the Health Check & Troubleshooting plugin
  • went into Troubleshooting mode
  • enabled Asgaros Forum plugin
  • went to front-end and clicked the Edit Profile link (the new one in your version)
  • but it still takes me to the main forum page and not to the new front-end profile editor page

in case you’re interested, I am attaching a ZIP archive to this post with screenshots of all of my settings

Thanks again for your assistance!

Uploaded files:

Thanks @johnstaples

I didn’t notice anything amiss in the settings screenshots

It’s a long shot, but look at your pages and make sure none of them use the slug “edit”.  I didn’t see any.

The only other thing I can think of at the moment – I noticed you have three categories.  Two of them appear on the ‘Forums’ page (with slug ‘forum’) which presumably has the forum shortcode.  The other, Songs, appears on a page with the slug ‘songsxx’.  I’m curious how you set that up to have 2 forum pages, and wonder if that could be the problem.

Can you temporarily convert the songsxx page into a draft, and see if that fixes it?  And undo whatever you did to split the forum like that if not too much trouble.

Hi @jim,

I removed all code from my functions.php file and then reinstalled a fresh copy of your forum plugin files. Then I removed that second forum page so now there is just a single forum instance. Also I confirmed I am not using the slug edit anywhere.

I am using the latest Wordpress 6.5.4

But the problem is still there. 🙁 Not sure what else to do. Maybe I’ll try a fresh install of Wordpress, install your version of the forum plugin and see if it is working before I do anything else.

As you probably noticed, my website is in a very early stage. I am putting this together and had used this forum in the past so I wanted to see if I could bend it to my will!

I have a question for you if you don’t mind?

Obviously, you have heavily modified the plugin code which means whenever Thomas releases a new version you’ll need to make all of your changes to the new version in order to upgrade. And sometimes I’d guess the changes might be unrelated so you’ll just install your code bits in the same approximate locations as they are now but sometimes things might change so significantly that you’d need to re-enginner your solution.

So, now to my question! How do you keep track of all of this? I usually keep a journal for each project documenting what I changed and, if I change the actual plugin code (I know, not usually recommended!) I make sure those notes are large font and bold! I also keep copies of original files and the modified files so I could always use a diff checker to find the changes in case my notes fail me.

So, any tips on keeping track of something like this once you decide to dive into the deep end? 😀

@johnstaples  Okay, this is very puzzling and I am about out of ideas. I wouldn’t bother with reinstalling Wordpress and the plugin.  I’m going to download the version I posted on this thread, install on my site, and see if it works as expected. If it does, then an explanation why it doesn’t work for you may be above my pay grade.

You’re right, it is complicated to merge all those changes.  I did write a file listing all the modifications in case I need it.  But mostly I use git versioning.  Git is confusing to me and I have barely kept my head above water, but so far it has worked.

I forked the main Asgaros forum on github, then made a local clone of it.  I made a branch and made all my modifications (i’m simplifying, not that smooth.)

When Thomas updates Asgaros, I can update a local copy of it, then do a merge with my modified copy.  It has worked without me needing to do any copy and pasting.  So far I don’t think there’s been a conflict between our changes.  When it works, it is fast and easy.


Well the zip on the forum here worked for me, so I am officially stumped.  Unfortunately previous participants in this thread don’t get notifications unless they expressly subscribe, but maybe I can list a few hear and see if anyone else has tried the modified version of 2.9.

@gezondeculturen @jenny @workpage @asgaros

Have any of you tried the edit-profile modification of Asgaros 2.9 posted in this thread?  If so, are you having the problems that @johnstaples is having?  Namely, that clicking on the Edit Profile link in your profile goes to the main forum page.  It works for me and I’m out of ideas in figuring it out.

PreviousPage 3 of 4Next