Please or Register to create posts and topics.

Front-end profile editing

PreviousPage 2 of 3Next

Toolbox for Asgaros does not work with your plugin. With your plugin, the topic of the forum is not edited for yourself

@jim Thank you so much for the update!

And not sure, but I think @workpage is asking you to post all (future) updates here instead or as well as on GitHub.

Either way, I’ll test the plugin as soon as I can this week and post my findings here.

Thanks so much for sharing your work!!

newforum.top has reacted to this post.
newforum.top

@vadimmartin86

I tried changing some colors in the backend Forum > Appearance settings and had no problem (after doing a full page refresh on front end that clears the browser cache).  Can you be very specific about exactly what you’re trying to change that doesn’t work?  And what do you mean by “many functions also disappear”.  Things actually disappear from a page?  Front end or back end?

I can’t speak to the Toolbox; I’ve never used it.

There is no way to separately install the edit profile functionality; it is integrated into the plugin.

newforum.top has reacted to this post.
newforum.top

@jim  If I go to Forum > Forum Appearance and try to change something there, nothing works for me. The theme does not change color, font, font height.
Toolbox
works with the usual planig Asgaros, does not work with yours
Appearance>Settings>Additional styles. I enter my styles, there is nothing on the site for me

 

Quote from vadimmartin86 on September 4, 2023, 8:28 pm

@jim  If I go to Forum > Forum Appearance and try to change something there, nothing works for me. The theme does not change color, font, font height.
Toolbox
works with the usual planig Asgaros, does not work with yours
Appearance>Settings>Additional styles. I enter my styles, there is nothing on the site for me

 

@vadimmartin86 That’s strange.  I just retested and had no problem changing colors in the Appearance page.  Did you remember to scroll all the way down and click “Save Appearance”?  If so, maybe there is some conflicting custom php or css?

As I said, I’m not familiar with Toolbox.   I just installed it and don’t find anything like Appearance > Settings > Additional styles.  Also I don’t find it in regular Asgaros Forum.

newforum.top has reacted to this post.
newforum.top
Quote from Jim on September 4, 2023, 11:14 pm
Quote from vadimmartin86 on September 4, 2023, 8:28 pm

@jim  If I go to Forum > Forum Appearance and try to change something there, nothing works for me. The theme does not change color, font, font height.
Toolbox
works with the usual planig Asgaros, does not work with yours
Appearance>Settings>Additional styles. I enter my styles, there is nothing on the site for me

 

@vadimmartin86 That’s strange.  I just retested and had no problem changing colors in the Appearance page.  Did you remember to scroll all the way down and click “Save Appearance”?  If so, maybe there is some conflicting custom php or css?

As I said, I’m not familiar with Toolbox.   I just installed it and don’t find anything like Appearance > Settings > Additional styles.  Also I don’t find it in regular Asgaros Forum.

Hello. Here’s how I manage to change the settings on the site. This is the font, font height, theme colors

Uploaded files:
  • Screenshot_10.png

Here is the Asgaros Forum 2.7.0 update with the edit-profile functionality merged in.  I remain unable to replicate any problem with editing colors etc.

Uploaded files:

Hi @jim

Thanks for the continuous updates. I will try to merge your changes with the next version (v2.8) into the plugin.

Jim and newforum.top have reacted to this post.
Jimnewforum.top
If you want to support the development of Asgaros Forum, you can leave a good review or donate. Thank you very much!

The front-end editing looks fantastic – exactly what I have been looking for!

Have you been able to implement it into v2.8? I wouldn’t want to downgrade to be able to use it.

Quote from Jenny on March 11, 2024, 1:39 am

The front-end editing looks fantastic – exactly what I have been looking for!

Have you been able to implement it into v2.8? I wouldn’t want to downgrade to be able to use it.

Yes, it is attached.

Uploaded files:
PreviousPage 2 of 3Next